TEEM - Scheduled Product Release Notification

Scheduled for Jan 28, 05:30 - 09:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 22, 2026 - 03:38 UTC

Scheduled

Scheduled Release Date: January 28, 2026

As part of our regular maintenance and release cycle, we will be deploying an update to TEEM on January 28, 2026. This release includes backend improvements and feature updates to ensure continued reliability and performance.

You may observe momentary interruptions as systems update. These are expected to be minimal and self-resolving.

If you would like to know what is coming in this release, please refer to the 'What's New' page. [https://knowledge.eptura.com/Teem/Whats_New]
Posted Jan 22, 2026 - 03:31 UTC
This scheduled maintenance affects: Teem.