AWS Outage Impacting Eptura Services

Incident Report for Eptura

Resolved

The AWS incident we have been monitoring has been resolved and all AWS services have returned to normal operations.
The current status can be followed here:
https://health.aws.amazon.com/health/status.

This incident directly impacted several Eptura services, including Serraview, Archibus, Visitor and SpaceIQ.

We are continuing to monitor all Eptura services to ensure that everything returns to normal operations.

Both Serraview and Archibus services are accessible. Users may continue to experience intermittent issues as AWS progresses with its backlog of queued events

SpaceIQ has reported that the entire web and mobile application fails intermittently with customers receiving a time out error. AWS continues to work through the backlog of queued events at this time. Additionally,

Eptura Visitor integrations with third-party services such as SMS notifications have experienced disruptions.

We appreciate your patience and will provide our next update by October 21st, 13:00 UTC.
Posted Oct 21, 2025 - 00:01 UTC

Update

The AWS incident we have been monitoring has been resolved and all AWS services have returned to normal operations. The current status can be followed here: https://health.aws.amazon.com/health/status. This incident directly impacted several Eptura services, including Serraview, Archibus, Visitor and SpaceIQ. We are continuing to monitor all Eptura services to ensure that everything returns to normal operations. Both Serraview and Archibus services are accessible. Users may continue to experience intermittent issues as AWS progresses with its backlog of queued events SpaceIQ has reported that the entire web and mobile application fails intermittently with customers receiving a time out error. AWS continues to work through the backlog of queued events at this time. Additionally, Eptura Visitor integrations with third-party services such as SMS notifications have experienced disruptions. We appreciate your patience and will provide our next update by October 21st, 13:00 UTC.
Posted Oct 20, 2025 - 23:54 UTC

Update

We are continuing to monitor an ongoing incident reported by AWS, which can be followed here: https://health.aws.amazon.com/health/status.

AWS continues to make progress toward pre-event levels in all Availability Zones and we are continuing to monitor Eptura services.

This incident directly impacted several Eptura services, including Serraview, Archibus and SpaceIQ.

Both Serraview and Archibus services are accessible. Users may continue to experience intermittent issues as AWS progresses with its recovery efforts.

SpaceIQ has reported that the entire web and mobile application fails intermittently with customers receiving a time out error. AWS is working through the backlog of queued events at this time.

Additionally, Eptura Visitor integrations with third-party services such as SMS notifications have experienced disruptions.

We appreciate your patience and will provide our next update by 23:00 UTC.
Posted Oct 20, 2025 - 19:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 16:11 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 16:10 UTC

Update

We are continuing to monitor an ongoing incident reported by AWS, which can be followed here: https://health.aws.amazon.com/health/status.

This incident directly impacted several Eptura services, including Serraview, Archibus and SpaceIQ.

Both Serraview and Archibus services are now accessible, however users may continue to experience intermittent issues as AWS progresses with its recovery efforts.

SpaceIQ is reporting that the entire web and mobile application fails intermittently with customers receiving a time out error.

Additionally, Eptura Visitor integrations with third-party services such as SMS notifications have experienced disruptions.

We appreciate your patience and will provide our next update by 19:00 UTC.
Posted Oct 20, 2025 - 15:01 UTC

Monitoring

We are currently monitoring an ongoing incident reported by AWS, which you can follow here: https://health.aws.amazon.com/health/status.
This incident has directly impacted several Eptura services, including Serraview and Archibus. While both services are now accessible, users may continue to experience intermittent issues as AWS progresses with its recovery efforts.
Additionally, Eptura Visitor integrations with third-party services—such as SMS notifications—experienced disruptions.
We appreciate your patience and will provide our next update by 15:00 UTC.
Posted Oct 20, 2025 - 10:54 UTC
This incident affected: Serraview by Eptura (Space Planning, Core Services, Engage, Insights, Public API, SV Live / Locator, Advanced Imports, Floorplan, Reports, SFTP), Archibus by Eptura, SpaceIQ, and Eptura Visitor (Integrations, Kiosk).