[Eptura Engage] S2 - Bookings originated from Exchange are not synching to Eptura Engage

Incident Report for Eptura

Resolved

The issue has been resolved.
Posted Jan 19, 2026 - 14:11 UTC

Monitoring

Our Infrastructure team has increased the resource capacity and renewed the certificate.

Based on our preliminary validation, the issue now appears to be resolved. We will continue to monitor and update here.
Posted Jan 19, 2026 - 13:26 UTC

Investigating

We are currently investigating an issue wherein bookings originated from Exchange are not synching to Eptura Engage via M365 Integration.
Posted Jan 19, 2026 - 12:44 UTC
This incident affected: Eptura Engage (M365 Integration).