Microsoft has confirmed that the global Azure incident causing service disruptions has been fully resolved. As this was the underlying cause of the recent issues, we are now marking this incident as resolved.
We appreciate your patience and understanding while this issue was being investigated and remediated.
Posted Oct 30, 2025 - 03:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 22:46 UTC
Update
Update – Microsoft has implemented recovery measures for the global Azure incident, and services are stabilizing. Engage and Visitor are now functional and we are awaiting confirmation on the remaining impacted Eptura services listed below:
Platform-V2 Core Services Workplace Hummingbird Outlook Plug-in
Our teams continue to monitor progress and will provide further updates as stability improves.
Thank you for your patience during this recovery process.
Posted Oct 29, 2025 - 22:43 UTC
Update
Microsoft has implemented recovery measures for the global Azure incident. As these changes propagate through Azure, we are beginning to see partial recovery of impacted services. Please note that availability remains intermittent for the following Eptura services:
Engage Outlook Plug-in Engage Device Hub Visitor Outlook Plug-in Calendar syncing between Engage and Exchange Platform-V2 Core Services Workplace Hummingbird Outlook plug-in
Our teams continue to monitor progress and will provide further updates as stability improves. Thank you for your patience during this recovery process.
Posted Oct 29, 2025 - 19:56 UTC
Update
Microsoft has implemented recovery measures for the global Azure incident. As these changes propagate through Azure, we are beginning to see partial recovery of impacted services. Please note that availability remains intermittent for the following Eptura services:
Engage Outlook Plug-in Engage Device Hub Visitor Outlook Plug-in Calendar syncing between Engage and Exchange Platform-V2 Core Services
Our teams continue to monitor progress and will provide further updates as stability improves. Thank you for your patience during this recovery process.
Posted Oct 29, 2025 - 19:38 UTC
Update
We have identified that the issues currently affecting Eptura Engage, Eptura Visitor, and Eptura Platform V2 are related to a global Microsoft Azure incident.
Impacted Services: Engage Outlook Plug-in Engage Device Hub Visitor Outlook Plug-in Platform-V2 Core Services
Additionally, syncing of calendar events between Engage and Microsoft Exchange may experience intermittent disruptions.
Our teams are actively monitoring the situation and we will continue to update this incident.
Posted Oct 29, 2025 - 19:02 UTC
Identified
We have identified that the issues currently affecting Eptura Engage and Eptura Visitor are related to a global Microsoft Azure incident.
Impacted Services: Engage Outlook Plug-in Engage Device Hub Visitor Outlook Plug-in
Additionally, syncing of calendar events between Engage and Microsoft Exchange may experience intermittent disruptions.
Our teams are actively monitoring the situation and we will continue to update this incident.
Posted Oct 29, 2025 - 17:46 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:40 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 16:57 UTC
Investigating
We have received reports of Engage Outlook add-in and Device Hub not loading. While our teams are investigating the issue, it seems to be related to recently reported Microsoft outage affecting multiple systems.
Posted Oct 29, 2025 - 16:53 UTC
This incident affected: Eptura Engage (Device Hub, Outlook Add-In), Eptura Workplace, and Eptura Visitor (Integrations).