S2 Eptura Asset - 503 Connection Error

Incident Report for Eptura

Resolved

We’re pleased to share that the issue has now been resolved. Both our internal teams and external users have confirmed that all services are functioning as expected.

We sincerely appreciate your patience and understanding while we worked to restore normal operations.

Our team is preparing a detailed Root Cause Analysis, which will be published within the next 10 business days.

Thank you for your continued trust and partnership.
Posted Mar 12, 2026 - 20:16 UTC

Monitoring

Earlier this morning, Eptura Asset experienced a brief service degradation that caused some customers to encounter system slowness or receive intermittent 503 Connection Errors.

The issue lasted for under 10 minutes and affected a subset of customers attempting to access Eptura Asset services.

Our engineering team identified the cause immediately, and recent platform updates allowed for a rapid recovery. Normal performance was fully restored shortly after detection.

We continue to monitor the system closely and are reviewing the incident to ensure resilience against similar issues in the future.

We apologize for any inconvenience this brief disruption may have caused and appreciate your patience.

We will attach an RCA as soon as we have the details from engineering.
Posted Mar 12, 2026 - 15:50 UTC
This incident affected: Eptura Asset.