Eptura Visitor - S2 - Intermittent ACS Integration Issues

Incident Report for Eptura

Monitoring

We are continuing to actively monitor while our teams work towards identifying a root cause.

A secondary issue was identified and resolved at approximately 10:00 UTC today. Some users may have received "server offline" notification emails in error. This was a repercussion of the ongoing incident and has now been addressed.

We will continue to provide updates as more information becomes available.

Thank you for your patience.
Posted May 26, 2026 - 16:11 UTC

Update

Our engineering team continues to monitor the previously identified intermittent issues affecting visitor pass processing for a small number of customers using Access Control System (ACS) integrations.

Following the steps taken late last week system performance has remained stable, and we have received confirmation from at least one previously affected customer that functionality is now operating as expected.

We have proactively followed up with impacted customers and are currently awaiting additional confirmation.

At this time, the overall system continues to perform reliably, and no widespread issues are being observed. Our team remains actively engaged in validating a full resolution and confirming the root cause to prevent recurrence.

We understand the importance of consistent and dependable visitor management and appreciate your continued patience. We will provide further updates as soon as additional confirmations are received or new findings emerge.
Posted May 25, 2026 - 15:21 UTC

Identified

We recently identified intermittent issues impacting visitor pass processing for a small number of customers using ACS integrations. These issues caused some visitor actions, such as access updates and check-in or check-out syncing, to behave inconsistently.

As a precaution, we rolled back recent optimizations related to the Access Control System (ACS) integration. Since then, we have seen a strong improvement, and affected processes are now functioning as expected in most cases.

Our engineering team is continuing a thorough investigation to confirm the root cause and ensure a long-term resolution. While one or two isolated cases are still being reviewed, the overall system is stable.

We understand how important reliable visitor management is to your operations and appreciate your patience as we complete our investigation. We will share another update as soon as we have confirmed the root cause and next steps.
Posted May 22, 2026 - 18:39 UTC

Update

We have rolled back recent optimizations related to the Access Control System (ACS) integration and restarted the routing services.

Initial testing following these changes has shown positive results, with improved stability observed across affected workflows. However, due to the intermittent nature of the issue, we are continuing to closely monitor system behavior and conduct further validation.

Our Engineering and Infrastructure teams remain actively engaged in ongoing analysis to confirm full resolution and identify the root cause.

We will continue to provide updates as more information becomes available.
Thank you for your patience.
Posted May 22, 2026 - 09:17 UTC

Update

We are continuing to investigate the intermittent issues affecting the Visitor integration with Access Control Systems (ACS). Customers may still experience inconsistent behavior across workflows such as visitor creation, access updates, token management, and check-in and check-out.

Our Engineering and Infrastructure teams are actively working to identify the root cause through ongoing analysis of system behavior. At this stage, the underlying cause has not yet been confirmed, and further investigation is in progress.

We will share the next update as soon as we have more clarity on the root cause and identified next steps.

Thank you for your patience while we work towards resolution.
Posted May 22, 2026 - 08:33 UTC

Update

We are currently investigating intermittent issues affecting the Visitor integration with Access Control Systems (ACS). Customers may experience inconsistent behavior across workflows such as visitor creation, access updates, token management, and check-in/check-out.

The issue appears sporadic with no clear pattern. Our Engineering and CloudOps teams are working to identify the root cause and determine next steps. As part of this effort, additional engineering analysis is required and is scheduled to begin tomorrow morning IST.

At this time, we do not anticipate any new updates until the analysis is underway and initial findings are available. We will provide a follow-up as soon as more information becomes available.
Posted May 21, 2026 - 20:42 UTC

Investigating

We are investigating intermittent issues affecting the Visitor integration with Access Control Systems (ACS). Customers may experience inconsistent behavior across workflows such as visitor creation, access updates, token management, and check-in/check-out.
The issue appears sporadic with no clear pattern. Engineering and CloudOps teams are actively working to identify the root cause and resolve the issue.
We will provide further updates as more information becomes available.
Posted May 21, 2026 - 15:36 UTC
This incident affects: Eptura Visitor (Access Control).