We are pleased to inform you that the issue with Insights Down for US and AU clients has been resolved. Our Engineering team has completed the necessary actions and verified that the service is now functioning normally.
A Root Cause Analysis (RCA) will be conducted to understand the incident in detail and will be made available on our Status Page within 10 days.
Thank you for your patience and cooperation throughout this process. If you have any further questions or concerns, please feel free to reach out.
Posted Apr 13, 2026 - 21:35 UTC
Monitoring
The hotfix has been successfully deployed across affected regions to address the issue related to authentication keys not being recognized.
We are now monitoring the system to ensure stability and confirm that the issue has been fully resolved.
If you continue to experience any issues, please reach out via your existing support case or open a new one.
Thank you for your continued patience and understanding.
Posted Apr 13, 2026 - 05:11 UTC
Update
We have made further progress in our investigation and identified the issue related to authentication keys not being recognized.
Our engineering team is currently implementing additional safeguards and preparing the fix for deployment as part of the upcoming release this weekend.
We will provide our next update by Monday, April 13. If you experience any issues, please contact us through your existing support case or open a new one.
Thank you for your continued patience and understanding while we work on a permanent fix.
Posted Apr 08, 2026 - 10:35 UTC
Identified
We have identified the root cause of the issue and are now in the remediation phase. A temporary mitigation has been implemented and remains in place to reduce customer impact while our engineering team continues work on a permanent solution.
Engineering efforts are underway to prepare a build for deployment across affected regions to fully resolve the underlying issue. This work is actively in progress.
We will continue to share updates as new information becomes available. If you experience any issues, please contact us through your existing support case or open a new one. Thank you for your continued patience and understanding.
Posted Apr 07, 2026 - 22:41 UTC
Update
Our engineering team continues to actively investigate the issue and work toward a permanent resolution.
Efforts are underway to prepare a build for deployment across affected regions, with the goal of addressing the underlying issue. This work is currently in progress.
The temporary mitigation remains in place and continues to help reduce customer impact.
We will share further updates as more information becomes available. If you experience any issues, please reach out to us via your existing case or raise a new support case. Thank you for your continued patience and understanding.
Posted Apr 07, 2026 - 08:45 UTC
Investigating
We’ve moved this incident back to Investigating while our engineering team continues to look into the root cause.
A temporary fix is in place to help reduce impact, and we’re actively working toward a permanent solution.
We’ll share more updates as soon as we have additional information. Thank you for your continued patience and understanding.
Posted Apr 06, 2026 - 19:20 UTC
Identified
The issue causing Insights to be unavailable for US and AU clients has been identified, and a fix is currently being implemented.
We will provide additional updates as more information becomes available. Thank you for your patience.
Posted Apr 06, 2026 - 16:43 UTC
Investigating
We are currently investigating an issue impacting Insights for clients in the US and Australia. Our Engineering team is currently investigating to determine the cause of the disruption. Next update will be posted at 2:30 PM CST
Posted Apr 06, 2026 - 15:32 UTC
This incident affected: Serraview by Eptura (Insights).