Over the past several days, we have not observed any further instances of the server connection error previously reported. Additionally, we have not received any new customer reports indicating the issue is continuing. As service has remained stable and no further disruptions have been detected, we will be moving this incident into the Resolved phase. Thank you for your patience while we monitored the situation. Please remain subscribed to this page to receive any future updates automatically.
Posted Mar 25, 2026 - 14:06 UTC
Update
Our engineering teams continue to make progress on resolving the server connection issues currently impacting some users. We have implemented several adjustments and improvements over the past week, which have resulted in increased stability for many customers. While these changes have helped reduce the frequency of connection disruptions, additional work is still required to fully restore optimal performance. The teams are actively developing long‑term, permanent solutions that include code-level improvements and additional server deployments to enhance overall reliability and scalability. We will continue to provide updates as work progresses. Thank you for your patience while we work to fully resolve this issue.
Posted Mar 23, 2026 - 16:58 UTC
Update
We have not observed any further occurrences of the issue that previously impacted Eptura Asset performance.
The environment remains stable, with the automated recovery mechanism effectively handling any spikes in activity.
Our engineering team continues to work on a long-term solution to address the root cause and prevent recurrence. We will share further updates as progress is made.
Thank you for your continued patience.
Posted Mar 23, 2026 - 09:01 UTC
Update
Over the past 24 hours, we have not observed any further occurrences of the issue that previously impacted Eptura Asset performance.
The automated recovery mechanism implemented by Eptura designed to respond when server thread counts spike has been functioning as expected and has successfully stabilized the environment.
At this time, we continue to work closely with the Eptura Asset Engineering team. They are still developing a preventive, long‑term fix to address the underlying root cause and permanently eliminate the risk of recurrence. We will provide additional updates as soon as engineering delivers the preventive solution or if conditions change. Thank you for your patience.
Posted Mar 20, 2026 - 17:48 UTC
Update
We are continuing to investigate reports of intermittent connection issues affecting some users. You may experience brief disruptions when attempting to connect to the service.
Our teams are actively monitoring system performance and working to identify the underlying cause. Automation and recovery mechanisms remain in place to reduce service impact while we continue to work toward a permanent resolution.
We will provide the next update as soon as more information becomes available. Thank you for your patience and understanding.
Posted Mar 19, 2026 - 15:25 UTC
Monitoring
The application is now stable and operating as expected. We will continue to monitor the situation. If you experience any issues, please reach out to Support via your existing case or raise a new one.
Thank you for your patience and understanding.
Posted Mar 19, 2026 - 10:05 UTC
Update
Our Infrastructure and Engineering teams are continuing to work to identify the underlying cause and implement a fix as quickly as possible. At this time, you may notice slow load times or degraded functionality within the platform. We understand the impact this may have on your operations and sincerely apologize for the disruption. Further updates will be provided here as soon as more information becomes available. Thank you for your patience while we work to restore full performance.
Posted Mar 18, 2026 - 22:55 UTC
Update
We are continuing to observe intermittent 503 errors today.
Our alerting systems are actively firing, and our teams are closely monitoring the situation while addressing issues as they arise.
We are currently reviewing application logs to identify the underlying cause and are working toward a permanent resolution.
Additional updates will be provided as soon as more information becomes available. Thank you for your patience.
Posted Mar 18, 2026 - 14:28 UTC
Update
Our Infrastructure and Engineering teams are actively collaborating to identify the underlying cause and implement a fix as quickly as possible. At this time, you may notice slow load times or degraded functionality within the platform. We understand the impact this may have on your operations and sincerely apologize for the disruption. Further updates will be provided here as soon as more information becomes available. Thank you for your patience while we work to restore full performance.
Posted Mar 17, 2026 - 23:08 UTC
Investigating
We are currently investigating an issue where some customers are experiencing delays or intermittent interruptions when accessing Eptura Asset modules. Our infrastructure team is actively working to identify the root cause and restore full functionality as quickly as possible. We will provide an update as soon as more information becomes available. Thank you for your patience.