S2- Eptura Engage - Users are unable to log in to Engage when accessing the web application via xyz.condecosoftware.com/master.aspx URL, as the page redirects them to a logout screen.

Incident Report for Eptura

Postmortem

We are grateful for your continued support and loyalty. We value your feedback and appreciate your patience as we worked to resolve this incident.

 

Type of Event:

S2 - Eptura Engage - Users are unable to log in to Engage when accessing the web application via xyz.condecosoftware.com/master.aspx URL, as the page redirects them to a logout screen

 

Services/Modules Impacted:
Eptura Engage Web Application

 

Issue Summary/Background:
Eptura Engage Web Application — Login attempts made using bookmarked or redirected URLs (e.g., xyz.condecosoftware.com/master.aspx). Logins using the root URL (xyz.condecosoftware.com) were not impacted.

 

Root Cause:

During the Evergreen update applied over the weekend of 30–31 August 2025, a security configuration change was introduced to strengthen login controls. This update restricted logins to only the root URL. As a result, users attempting to log in via bookmarked or redirected URLs were redirected to a logout screen instead of reaching the login page.

 

Remediation:

Engineering developed and validated a configuration fix that restored login support for non-root URLs. The fix was rolled out globally on 1 September 2025, after successful testing in a controlled environment. Customers confirmed that login functionality was restored once the rollout was complete.

Timeline (Timezone):

31 August 2025
23:14 UTC – First customer reported login issues when accessing Engage via a bookmarked URL.
23:58 UTC – Support escalated the issue to CloudOps for investigation.

01 September 2025
02:32 UTC – Ten customer cases confirmed with the same login failure symptoms.
04:48 UTC – Severity officially updated to S2 due to increasing customer impact.
05:00 UTC – Status Page created with initial outage details and guidance to access via the root URL.
06:28 UTC – Engineering team engaged to assist in root cause analysis.
06:45 UTC – Engineering identified a configuration change as the cause and provided a fix. The fix was tested successfully in a customer UAT environment.
09:52 UTC – Engineering confirmed the configuration fix could be safely deployed in bulk across environments.
11:30 UTC – CloudOps initiated the global deployment of the fix.
16:10 UTC – Global deployment completed; login functionality restored for bookmarked and redirected URLs.

02 September 2025
10:55 UTC – Status Page updated to “Resolved” following confirmation that normal login access had been fully restored.

 

Total Duration of Event:

16 hours 56 minutes

 

Preventive Actions:

To prevent recurrence, Eptura is implementing the following improvements:

  • Enhanced release communication – All changes with potential customer impact will be documented and highlighted in release notes.
  • Extended testing coverage – Login scenarios for both root and non-root/bookmarked URLs will be included in test suites.
  • Change review enhancements – Product, Engineering, and Support will jointly review security and configuration changes to assess customer impact before release.
  • Updated customer guidance – Documentation will be updated to clarify recommended login methods and best practices for bookmarking.
Posted Sep 09, 2025 - 13:22 UTC

Resolved

This incident is now being marked as Resolved. Detailed root cause analysis will be shared on this page in 10 days.
Posted Sep 02, 2025 - 10:55 UTC

Monitoring

The fix has been implemented on the system. We shall keep this under monitoring till 0600 UTC on 2nd September 2025.

Detailed root cause analysis shall be shared in 10 business days.
Posted Sep 01, 2025 - 16:19 UTC

Update

We are continuing to work on the fix Globally and it is targeted to be completed by 18:30 UTC/Midnight IST.
Posted Sep 01, 2025 - 14:11 UTC

Identified

We've identified the issue causing the current outage and will be applying a configuration change to resolve it. This will result in approximately 10 minutes of downtime, starting at 11:30 AM UTC / 5:00 PM IST.

We’ll post an update once the work is completed.

Thank you for your understanding.
Posted Sep 01, 2025 - 10:47 UTC

Investigating

Our infrastructure team is actively investigating an intermittent issue where some users are being redirected to a logout page when attempting to access the application through the master.aspx URL.

As a temporary Workaround:
To continue operations without disruption, users are advised to log in using the application base URL https://xyz.condecosoftware.com/ (replace XYZ with your company name) in incognito/private mode.

We recognize the inconvenience this may cause and want to assure you that resolving this issue is a top priority. Our teams are working diligently to identify and implement a fix.

We will continue to provide updates as soon as more information becomes available.

Thank you for your understanding and patience.
Posted Sep 01, 2025 - 05:00 UTC
This incident affected: Eptura Engage (Web Application).